'76 Buick 350 -4 BBL backfires after tune up

Discussion in 'Small Block Tech' started by Seven6Regal, Apr 21, 2018.

Tags:
  1. Seven6Regal

    Seven6Regal Well-Known Member

    Hi V8 Buick,

    I replaced wires, ignition coil, ignition module, cap / rotor, spark plugs, fuel filter and air cleaner; and the car is running like crap. Cylinders 4 & 6 are a little rich, the others are fine. The engine idles a bit rocky, the car sputters on take off in drive and reverse. It also back fires while driving whether on or off the throttle. I cleaned the carb as well. I'm planning to install exhaust and header but hopefully I can sort this issue before installing the exhaust and headers. Any help is always appreciated. Thanks.
     
  2. buick64203

    buick64203 Just plum crazy Staff Member

    So to be clear, this issue started after the tune up? Are you sure you dont have 2 wires crossed?
     
    techg8 likes this.
  3. hugger

    hugger Well-Known Member

    Yea you got wires crossed up
     
  4. alec296

    alec296 i need another buick

    Check wires 5 and 7 . Most common crossed . But 4 and 6 could be as you mentioned alittle rich. .
     
    techg8 likes this.
  5. Seven6Regal

    Seven6Regal Well-Known Member

    I'll check in the morning.
     
  6. stk3171

    stk3171 Well-Known Member

    try 4 and 6 are swaped
     
    rkammer likes this.
  7. rkammer

    rkammer '71 GS455 Arctic White

    Yup, I've vote for 4 & 6 swapped.
     
  8. Seven6Regal

    Seven6Regal Well-Known Member

    4 and 6 were swapped. Car runs much better now. Thanks for the replies.
     
    MrSony likes this.

Share This Page