Anyone Do Testing on Instrument Clusters?

Discussion in 'Interior City' started by Moring, Jun 12, 2019.

  1. Moring

    Moring Well-Known Member

    This 70 cluster I've been working with has been spotty: the rally gauge has been iffy: it almost always notes an empty tank. The left turn seems to only work with the lights on. The dimmer's questionable.

    I figured these would all work themselves out when the new Letric harness was installed, the dash bulbs were replaced, a new tach has been installed, etc.

    And now this "freshened" one is still showing the same symptoms.

    Between dealing with all the garbage China Parts Place and OPGI parts, I've about reached my limit on frustration. Does anyone do any sort of wiring checking on dashes & all its components? I'm curious if someone does this as a service.
     
  2. telriv

    telriv Well-Known Member

    There are many Mass people on this forum. Put it in the correct thread & ask for help.
     
  3. Dr. Roger

    Dr. Roger Stock enthusiast

    When I restored the dash in mine, it had multiple different issues, which may be your case. Speedo was way off by 10 mph (it was shot and had to be replaced), fuel gauge was dicey (sending unit in the tank needed replacing), bad turn signal light sockets in the bumpers (a common problem with those GM sockets) that made the dash indicator lights do funky things, bad grounds, etc. Took a lot of trial and error to finally work all the bugs out... it was definitely frustrating.
     
  4. Redmanf1

    Redmanf1 Gold Level Contributor

    One thing is to make sure that the grounds are good on the dash housing....
     

Share This Page