Non Buick. Ford Super Duty Electrical issue

Discussion in 'The "Other" Bench' started by Briz, Sep 13, 2020 at 12:05 PM.

  1. Briz

    Briz Platinum Level Contributor

    KIMG0338.JPG This is my 01 F250. 7.3L Got in the truck yesterday to go into town and I heard this rapid clicking under the dash. Put the key in and its to dead to crank fast enough to start. Jumped her off and the noise continues but faster now. Oh well, hit the road. First thing I notice is the OD OFF light in the shifter handle is blinking. Switch works, just blinking. Then I see the speedo needle bouncing like crazy. I go on my way. start hearing a buzzer noise but muffled. Turn down the radio and its coming from under the dash. Oh well finish my mission. Get home and park on the concrete cause I know I'll be going under there tomorrow. come out in the morning and the cargo + int dome light is on too.
    Watched some you tube vids and it says the VSS is bad (vehicle speed sensor) shows its on the top of the rear diff. Shows how to ohm it out ect. another showed chafed wires leading to that sensor. Put her up in the air. checked all the wires. no problem. sensor OHM'd as good. Pulled off the lift. test drive and the problems gone. Have no idea what I did or what the problem was. I believe it will probably come back again. Anyone have an idea?
     
  2. pbr400

    pbr400 68GS400

    Ford used a sensor on the rear diff of all their rear drive stuff for about a decade, and failure is a feature. If I remember correctly it’s a cheap part; may be smart to replace it anyway.
    Patrick
     
  3. Bens99gtp

    Bens99gtp Well-Known Member

    Isn't that just for the abs......i the speed sensor was tranny or tcase mounted depending on 2wd or 4wd
     
  4. 436'd Skylark

    436'd Skylark Sweet Fancy Moses!!!!!

    I think cluster failures are common on those trucks.
     
  5. Briz

    Briz Platinum Level Contributor

    Sorry vids on its side. Must be a way to fix it. Not smart enough.
     
  6. lemmy-67

    lemmy-67 Gold Level Contributor

    Change the radio station, see if that helps. ;)
     
  7. Briz

    Briz Platinum Level Contributor

    Its always on Classic Rock. Once it got switched to country station and it started missing. millage went way down until I discovered the issue.
     
  8. lemmy-67

    lemmy-67 Gold Level Contributor

    Lucky you changed it back in time...you could have lost not only the truck, but the farm, your girl, the cow, etc... ;)
     
    Briz likes this.
  9. Guy Parquette

    Guy Parquette Platinum Level Contributor

    Was it shifting ok? I worked at a Ford dealer for 18 years and around those times and like said speed sensor in trans or the cluster. I would bank on the sensor.
    If you drink enough beer, the truck, the farm, the girl, and the cow will come back but not sure if you want the girl back....depends
     
    lemmy-67 likes this.
  10. 436'd Skylark

    436'd Skylark Sweet Fancy Moses!!!!!

    I find out in the country the cow and the girl are usually one in the same.
     
    Guy Parquette likes this.
  11. Briz

    Briz Platinum Level Contributor

    It seemed to be. Also seemed to have more power. Drove it again yesterday and its back to normal. Nearly 300K If something needs to be fixed Im cool with it!
     
  12. Guy Parquette

    Guy Parquette Platinum Level Contributor

    Hahaha

    Then it's probably not the cluster.
     

Share This Page