Odd problem...... hopefully someone knows....

Discussion in 'The "Juice Box"' started by cobravii, Aug 8, 2018.

  1. cobravii

    cobravii Well-Known Member

    Ok, So I've finally got my '64 Electra convertible on the road after a 10 years resto. One of the upgrades I made was to go to a 4L60E transmission. I used a shiftworks tail shaft housing so that I can use the original speedo. I noticed my speedo wasn't showing speed but the odometer is working. Then I noticed the the speedo does show speed but only in reverse! I should also mention I am using a 140 mph speedo from a Riviera. The speedo cable is new.

    Anyone have any ideas?

    TIA
    Larry
     
    Nailhead Ronnie likes this.
  2. telriv

    telriv Well-Known Member

    The type of speedo, Riv, should have NO affect. Probably a bad head. Send it out for repair.


    Tom T.
     
    Nailhead Ronnie likes this.
  3. BRUCE ROE

    BRUCE ROE Well-Known Member

    It does sound like the speedo output gearing you added is reversed. Bruce Roe
     
    Nailhead Ronnie likes this.
  4. cobravii

    cobravii Well-Known Member

    I thought so too. I contacted Shiftworks (they sold me the tailshaft housing and speedo gears and they say theres no such thing :-(
     
  5. BRUCE ROE

    BRUCE ROE Well-Known Member

    I am a lot more likely to believe my own observations than what anyone tells me.
    Check the rotation direction of the cable coming into the back of the speedo. It
    should be in the same direction as the needle moving to higher speed. Bruce Roe
     
  6. cobravii

    cobravii Well-Known Member

    If it is a reverse rotation speedo gear would it still mesh with the factory speedo cable?
     
  7. black70buick

    black70buick Well-Known Member

    That is odd. The speedo cable should turn clockwise, if you remove the cable from the trans the speedo gear (or gear shaft) should turn clockwise when in a forward gear.
     
  8. HotRodRivi

    HotRodRivi Tomahawks sighted overseas

    Yout cable on either end but i think at the. Cluster not engaged all the way.
     
  9. cobravii

    cobravii Well-Known Member

    That's interesting. I will check that out.
     
  10. HotRodRivi

    HotRodRivi Tomahawks sighted overseas

    The only way it will turn a different direction is if it is on the other side of the tailhousing.
     
  11. HotRodRivi

    HotRodRivi Tomahawks sighted overseas

    A 4L60 e is an electronic 700r4. i put a 1992 700r4 in my 68 Riv. I bought a new cable. It was barly long enough. I had to find the shirtest possible route to the cluster without binding it.
     
  12. HotRodRivi

    HotRodRivi Tomahawks sighted overseas

    Make sure nothing broke off in the Riv cluster. Like a piece of old cable
     
  13. cobravii

    cobravii Well-Known Member

    I'm going to pull the speedo out on the weekend and check things out. The cable is more than long enough so I'm ok with that. I will check and make sure there isn't anything broke off where the cable goes in, thanks.
     

Share This Page