1966 Lesabre Carb issues

Discussion in 'The Mixing shop.' started by rick1966lesabre, Jun 2, 2018.

  1. Hi
    My 66 Lesabre was running great until last night. Tank got under 1/4 tank and the car just starting stitting and back firing and just running like absolute crap. Did I get some dirt in carb? The carb was new last year (Holly)

    Any help would be great

    Thanks
     
  2. 66electrafied

    66electrafied Well-Known Member

    How old is your fuel pump and filter?
    If it's something that just happened, then chances are it's simple, like an issue with points or a fried distributor cap. Backfiring can mean one of two things; - your fuel pump is dying and not supplying at the right time, alternately starving and flooding, or your filter packed it in causing the same issue, or there's a crack in your distributor cap causing a cross fire.
    And yes, don't get me going on Holley carbs; I've never been able to get one to run right. Is it 2 or 4 barrel?
     
  3. I put new fuel filter and new pump and is back to running like a champ! Thanks again
     
  4. 66electrafied

    66electrafied Well-Known Member

    Glad to have been some assistance, good to hear it worked out.
     
  5. lrlforfun

    lrlforfun Well-Known Member

    OK Rick: Please consider getting your tank cleaned out professionally. I had one done recently. $300. Sandblasted and epoxy coated. The contamination could easily re-occur giving you the same symptoms as you've experienced. Sorry for the horrible price. This seems to be a common problem due to age. Also, drop the tank and really check it before spending any dough. Mitch
     

Share This Page