Coan 20320-2 used converter PROBLEMS

Discussion in 'The "Juice Box"' started by Gary Bohannon, Nov 10, 2019.

  1. Gary Bohannon

    Gary Bohannon Well-Known Member

    Just bought this converter and I'm a little worried.
    1. Noticed a slight whine on start up.
    2. Dropped into gear with a thud.
    3. Stalls hard at 1500 rpm.
    4. Wont shift up when driven. (or cant feel a shift)
    5. Free wheels (coasts) when I let off the throttle.
    I did some reading and seems I could have a bad converter sprag. Could also have a tranny full of metal and trash from a broken converter.
    Any ideas out there?
     
    Last edited: Nov 11, 2019
  2. Gary Bohannon

    Gary Bohannon Well-Known Member

    I called Coan.
    Tod said the above symptoms are more like a transmission problem.
    So how could a converter swap cause all this mess?
     
  3. LARRY70GS

    LARRY70GS a.k.a. "THE WIZARD"

    Swap it back out ASAP and see. Are you sure you set the converter end clearance correctly and that the converter was fully seated?
     
  4. Gary Bohannon

    Gary Bohannon Well-Known Member

    Need to recheck clearance. Had to use washers due to bolt pad overlaping balance weight on flexplate.
     
  5. Gary Bohannon

    Gary Bohannon Well-Known Member

    Clearance was about 1/16".
    Converter has been checked and freshened up. No internal problems.
    So now I have to figure out what caused all the symptoms mentioned above.....freewheeling off the throttle, whine, didn't feel any shifting, into gear with a thud, and stalls hard at 1500.
     
  6. LARRY70GS

    LARRY70GS a.k.a. "THE WIZARD"

    The problem has to be in the transmission if the converter is OK. Drop the pan and make sure the filter and O ring are OK. Check the modulator, vacuum supply and Governor.
     
  7. Gary Bohannon

    Gary Bohannon Well-Known Member

    More problems.
    Coan put new bearings in the converter. Bolted it to an sfi plate from TA. Good clearances.
    Transmission had a small amount of fine brass in the pan. Cleaned and new filter and fluid.
    Now have squealing noise when break torquing on jack stands!
    And doesn't go into 3rd gear on jack stands.
     
    Last edited: Dec 17, 2019
  8. Gary Bohannon

    Gary Bohannon Well-Known Member

    Coan said send it back for a dyno test. really. Why didn't they do this when I sent it back and they put new bearings in it?
     

Share This Page